Oba-Q's Free Space >  サーバーネットワーク > CentOS > 自動実行しない??

自動実行しない??

連れ合いが青森出張から帰ってきました。
夕食に出たお土産?のアワビが美味でした・

さて昨日の続きではなく個人使用サーバーの話です。

Oba-Qサーバーはハード(CPUとチップセット)を
交換してから順調に働いてくれ、日常的なメンテは
リモートから行っていましたが、交換以降の2年半は
一度もサーバー機自体のコンソールやGUIから
操作していませんでした。
通常はそれで良いのですが、昨日書いたように
他のサーバー機が調子悪く、いじったこともあり、
ついでに見てみようと久しぶりにサーバー機自体の
GUIから操作しようとしたら、なんとマウスと
キーボードが使えない。。。^^;;
マウスとキーボードはワイヤレスですが、どぉやら
USBドングルのレシーバーがコケている模様。
他のを流用するか紐付きでやろうと思ったのですが、
Unifying規格のレシーバーを買い占めてあったことを
思い出しました。。。と言っても2個しかなかったものを
2個買っただけですが。ww

ubuntuでもできるのかもしれませんが、ペアリング用の
アプリが入っているWindowsを久方ぶりに立ち上げました。
使っていたマウス・キーボドとあっさりペアリング完了。
久しぶりのWindowsですのでアップデートのほうがよほど
時間がかかりましたけどぉ。(泣

しかしこのレシーバ、昨年2個今年に入って1個コケました。
7個中の3個ですからかなりの確率で転けてます。
しかしコケたのはサーバー用2個とメインデスクトップの
1個ですから、2個は常時、1個も使用頻度が他より極端に
高いものなので、逝かれるのは熱でしょうかね。

必要ないっていえばないんですが、サーバーは久しく
再起動していなかったので、一通り見たついでに再起動!
ここからが表題の件でなんとPPPoEが繋がりませぬ。。。
余計なことしちゃいましたか。^^;;;
2年半ほど前に書きましたが、nmcliコマンドを使いPPPoEで
接続するスクリプトを書いて、systemdに登録したはずで、
起動時に自動実行すなきゃおかしいのですが。。。?

で、ifconfigを叩いてみて分かりました。
PPPoEが利用するNIC名がenp7**になっています。
登録したコマンドにはepn3**と書いてある。。。??
つながらなくて当たり前です。。。よね。。

推測の域ですが、ハード更新前はWANとLAN用のNICを逆に
使っていたようです。
enp7**はLAN側でプライベートIPアドレスが設定されていて、
epn3**がPPPoEが使うWAN側だったということです。
覚えてはいないのですが、更新したときにきっと接続を
逆にしてしまい、繋がらんとか騒いで、慌てながら手動で
コマンド叩いて繋げている姿が目に浮かびますす。www

そして逆にしたまま再起動無しで現在に至っているため
発覚せずにいたけど、今回の再起動で登録してあった
自動実行スクリプトはNIC名違いで、なんの役にも
立たなかったというお粗末なお話でありました。。。^^;;

コマンド中のepn3**をenp7**に変更し再起動させてみると
無事PPPoEで接続ができました。
何度か試したので、その間このブログもダウンしたはずです。。。

ま、拙生のやることだからこんなもんです。@自爆

月曜日にやる予定だった装柱の仕上げは明日に変更になりました。
受電のための電力線と光が引き込まれればほぼおしまいです。

This entry was posted in CentOS, お仕事, サーバーネットワーク. Bookmark the permalink.

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です

このサイトはスパムを低減するために Akismet を使っています。コメントデータの処理方法の詳細はこちらをご覧ください